Website-Optimierung mit dem Google Pagespeed-Apache-Modul

Hab mich mal wieder etwas mit der Performance von Websites etc. auseinandergesetzt. Jeder kennt sicherlich die Tools für den Browser (Firebug, YSlow, Page Speed) womit man seine Website testen kann. Die Tools zeigen dann eventuelle Performancebremsen an und geben Tipps wie man diese beheben kann. Google hat aber zusätzlich zum Browser Add-on auch ein Page Speed-Modul für den Apache 2.2 veröffentlicht. Das Modul beinhaltet eine Reihe von Filtern, die die Auslieferung der Webseiten optimieren sollen.  So können zum Beispiel unnötige HTML-Attribute entfernt werden, mehrere CSS-Dateien kombiniert werden oder diverse Bildformate optimiert werden, bevor diese vom Webserver ausgeliefert werden.

Das Video zeigt den Vergleich. Auf der linken Seite ist mod_pagespeed aus und auf der rechten Seite an:
[youtube]http://www.youtube.com/watch?v=8moGR2qf994[/youtube]

Google stellt mod_pagespeed für x86 und x64 System zu Verfügung. Entsprechende Binaries für Ubuntu/Debian/CentOS/Fedora gibt es zum Download. Für die Installation auf eienm Debian-/Ubuntu-System muss man nur das entsprechende deb-Paket runterladen und mit dpkg -i mod-pagespeed-*.deb installieren. Anschließend nur noch mit /etc/init.d/apache2 restart den Apache-Webserver neustarten. Eventuelle Anpassungen des Page Speed Moduls können unter /etc/apache2/mods-available erledigt werden.
Ob das Page Speed-Module für Apache etwas bringt muss jeder selber ausprobieren. Am besten eine Messung mit Yslow oder Pagespeed vor der Aktivierung des Apache-Moduls machen und eine danach. Der Vergleich beider Messungen wird den Unterschied zeigen.

Seit Blog-Gründung 2006 schreibe ich hier mal mehr, mal weniger in dieses Blog zu Themen die mich interessieren. Bin auch zu finden bei Twitter, Facebook, Instagram und Google+.

Leave a Reply

2 Kommentare

  1. Das Modul ist zwar schön enthält aber noch zu viele Bugs, so das nach der Zeit der Speicher vollläuft oder die CPU Auslastung hoch geht.

    Habe es mehrere Tage auf verschiedenen Rechnern getestet und es war immer das gleiche.

  2. Ich habe das jetzt auch eine Weile auf 2 Servern in Nutzung und kann derartige Probleme nicht bestätigen. Werde mal etwas mehr Traffic auf den Maschinen erzeugen, vielleicht dann. Danke fürs Feedback.

Next ArticleVideo: Yoari & iBand - "Sweet Dreams" (nur mit iPhone & iPad)